Start Production Not Working For Me

I am the owner of Futurix.
When i click on start production it shows this

But when i reload it shows this

Seems like a bug please solve it,this can be huge loss for my business.

We are investigating and currently it appears to be a limited issue, but we are looking into the cause.

We have investigated and it appears to be a browser caching issue, we have forced an update of the scripts and will monitor for issues.

Still not working

What browser and operating system are you using? So we test against that. It is working for us when we test it on the server using your account.

If possible try in a different browser as well.

I started trying on phone.
Its working on that.
Thank You

Now it’s not working on phone either.
I tried on binge it’s not working on that too.
Please solve that bug

Please provide the following details,
For your phone:
OS version.

For your Desktop
OS Version,

What size of production order are you placing, try a smaller one for now.

We have reproduced your issue and have addressed the cause.