Fixed bug, map enables correctly!

I need to thank The Developers of this game because after “ages” the world map finally spawns correctly with the chrome browser, in the past it took me ages to get a decent map and had to enable the population density, to get a sort of view, and establish a company there, so no bug but a big thanks for the fix!!

Regards Callaars,


Always nice to get some love, thanks! :slight_smile:

1 Like

Map is not displaying on any browser I’ve tried, it is simply blank page. Could you please advise what to do?

This has been corrected. Thank you for posting.

For the past couple days, I’ve been trying to relocate one of my retail businesses, but the map will not load. It just stays as a blank screen. Strangely, the map works fine through the World Map function on the phone, but not through Relocate. I’ve tried different browsers, clearing cache and cookies, turning off adblock and any other extensions that could possibly interfere, etc, and the issue remains. Please, help.

@Memento_Discere, we are looking at this now. Thanks for the post.

The issue has been identified and corrected. You should have no problem now.

Thank you! Relocate map works beautifully again. :slight_smile:

1 Like