Stock dividends not completing payment

I was trying to reward my shareholders with a hefty dividend just now and the system has marked that I’ve paid. It’s clear that the cash was never taken from my funds and hasn’t gone to my shareholders either. I left the screen processing for 15 minutes but it didn’t make a difference.

I thought it used to pop up on the activity list as well xxx has received a dividend… but that didn’t show up. So maybe it’s starting to process and hanging somewhere unfinished

We will look into this. Thank you for posting.

I tried again to pay a dividend with the same result, but someone paid a dividend so maybe it’s a browser thing. I use Chrome. Is there a preferred browser that you recommend - one that all the testing is done in?
Also - for all the system messages that generally go deleted unread (x co shipped product, shipment received, invoice payment by…) some messages I would like to get are “X co paid you a dividend of 99g per share or a total of 9900g” and “You have been paid interest on you bonds in XTC co of 250g”
One more thing - paying a dividend should be a token BXP thing - say 10 or 20?

We currently do recommend Chrome. We are still looking into this issue.