Can't write mails

When I type some company’s full name and click on the already selected option it won’t select that company but when I type something close to it and click on it then it selects I am on phone

We think we see the issue. To make sure we are seeing what you are, could you post a screen shot or capture of what you are reporting here for us to make certain we are addressing your problem.

This i can click the GG motors but it won’t come there

Thank you, we have addressed the issue and it should now be working for you.

Still not solved I have sent a screen recording of my problem on the discord server

Are you using a smartphone/tablet. Currently GoVenture World works best with a computer. We will try and resolve this issue.


GoVenture World is not yet designed to be fully functional on smartphones so you may run into other issues as well. Try using a different browser on your phone.

Ultimately, you may need to play with a tablet or computer to get the full experience.

1 Like