Can not start the game

I have gone through the startup phase and am trying to name and start the holding company. I have entered everything but it keeps on saying enter stock symbol even though I already have. I have tried to re enter the stock symbol but it won’t let me change it. Also if i press the logout button it doesn’t do anything so i cannot log out and try again. I have tried pressing the cell phone button to turn on and nothing happens
This is very annoying please help and sort this out. You can also email directly to me using:

Thanks, HM Garnett

Hey, try using a different browser to see if that gets you past the stock symbol issue. Let us know what happens.

Hey again, please try using a computer, not smartphone or tablet, and let us know if it works. Be sure to use 3 or 4 letters only for the stock symbol.

If it does not, let us know the country in which you want your holding company and your stock symbol and we will do it for you so you can get past the tutorial.

HM … making sure you received our email that we completed the tutorial for you.

Yes, I received it. I am going to try the game right now Thanks, Hardi.